Welcome, Guest. Please Login or Register
Simufly.com
  News:
Please, register and enjoy discussing on Aviation and Flight Simulation with us
  HomeHelpSearchLoginRegister
 
Problem running INS in FS Labs Concorde v1.41 (Read 21 times)
Ray
Forum Member
*
Offline



Posts: 21
Cheshire, England
Gender: male
Problem running INS in FS Labs Concorde v1.41
Feb 19th, 2020, 8:00pm
 
Hello Marko, this is a cry for help? I have a problem with P3D v3.4 crashing to desktop and no entry in Event Viewer. By a process of elimination the crashes only occur when the INS is operational. When I leave it off and fly Concorde using TRK HDG the problem doesn’t occur. Neither does it happen with a default aircraft in a default install of P3D.

I suspect there is  a corrupt file in Windows but trying to find it is a nightmare. Does the CIVA / INS code require specific Microsoft C++ files for correct operation? Is there any chance a Windows update has overwritten a file causing these problems?

FS Labs support has advised a reinstall of Windows but that is very extreme. I wonder if you could suggest a way of fixing this problem please.
Back to top
 
 

Regards,
Ray
Cheshire, England
View Profile   IP Logged
Marco Ravanello
Forum Administrator
*****
Offline



Posts: 307

Gender: male
Re: Problem running INS in FS Labs Concorde v1.41
Reply #1 - May 30th, 2020, 11:36am
 
Hello Ray,

> crashing to desktop...when the INS is operational

In which phase of the flight does the crash occur?
Does it happen immediately when turning the INS ON or during flight?

> require specific Microsoft C++ files

Which version of CIVA are you using? 1.51?

Marco


Back to top
 
 
View Profile   IP Logged
Ray
Forum Member
*
Offline



Posts: 21
Cheshire, England
Gender: male
Re: Problem running INS in FS Labs Concorde v1.41
Reply #2 - May 30th, 2020, 12:05pm
 
Hello Marco,

The problem was eventually traced to a combination of FSDT GSX and / or SODE. There must be a memory conflict since the CTD didn't happen when the INS was turned off and Concorde flown using TRK HDG mode. It happened at the same locations presumably when GSX or SODE comes to life nearing the end of a flight. CIVA INS is certainly not the probem.

I'm fully up to date with CIVA since I have to use the version that ships with FS Labs Concorde.
Back to top
 
 

Regards,
Ray
Cheshire, England
View Profile   IP Logged
Marco Ravanello
Forum Administrator
*****
Offline



Posts: 307

Gender: male
Re: Problem running INS in FS Labs Concorde v1.41
Reply #3 - May 30th, 2020, 12:19pm
 
Hello Ray,

> The problem was eventually traced to a combination of FSDT GSX and / or SODE

wow, that was not easy!

> There must be a memory conflict since the CTD didn't happen when the INS was turned off

honestly I have no idea of what could cause this. CIVA code is quite stable and both should not interfere with nor be influenced by others add ons.

I'm happy you were able to solve your problem and sorry for being so late replying to your post

Marco




Back to top
 
 
View Profile   IP Logged
Ray
Forum Member
*
Offline



Posts: 21
Cheshire, England
Gender: male
Re: Problem running INS in FS Labs Concorde v1.41
Reply #4 - May 30th, 2020, 12:27pm
 
Hi Marco,

It was Andrew Wilson who suggested uninstalling and then reinstalling GSX / SODE as he had a similar problem with the Airbus.

The problem occured again this week so I uninstalled GSX (both 32 and 64 bit) and then installed just 32-bit GSX. SODE was enabled only for 32-bit. So far I've had four Concorde flights and no problems.

My nest step is to install GSX 64-bit but leave SODE disabled for a couple of Concorde flights. If those are okay then I'll enable SODE 64-bit. If the CTD starts again then it points to SODE 64-bit being the problem. The quick solution might be to disable 64-bit SODE when flying 32-bit Concorde.

No worries about your late reply. Lots going on in the world. Hope you stay  safe.  Smiley
Back to top
 
 

Regards,
Ray
Cheshire, England
View Profile   IP Logged